Changing the Default PHP Version in cPanel

On cPanel servers with Easy Apache 4 (EA4) or later, it is possible for end users to select the version of PHP the domains or subdomains you manage from within your cPanel account, so long as the server administrator permits you to do so.

Changing a Domain or Subdomain's Active PHP version

Start by opening the MultiPHP Manager interface by navigating to: cPanel >> Software and then clicking on MultiPHP Manager:

Check the boxes on the row of each domain you want to change in the Set PHP Version per Domain section:

Select the PHP version from the list on the right-hand side of the screen above the domain list, and then click Apply:

The altered domains should now reflect the updated PHP version accordingly in the list:

Can I Modify the PHP Version for a Single Directory?

Yes, this is possible in most cases under EA4, but unfortunately not from within cPanel itself. It requires manually adding some information to certain files in your account and is beyond the scope of this particular article.

Additional Questions

If you have additional questions not answered by this article and you're a client of ours, please contact us any time and we'll be glad to help.